dbQwikSite User Forum

Newbie needs help with WAMP server, please?
Page 1 of 1

Author:  anacht [ Mon Mar 22, 2010 12:24 am ]
Post subject:  Newbie needs help with WAMP server, please?

I want to be able to run and test my pages/db with WAMP. I have successfully downloaded and installed WAMP and created a MySQL db on the WAMP side.

I have gone to Tools--> Project Settings--> Local Settings and set:

Local Script Language = PHP
Root Directory = C:\wamp\www
Host Name: = local host
Port Number: = 80

When I click the TEST CONNECTION button I receive the message "Test Connection Successful".

Next, I use the DEPLOY WIZARD in an attempt to load my pages and MDB db to WAMP. Everything works fine until I get to the dbQwikSite FileZilla Tool. I set:

Host = localhost
user id = root
password = [leave blank]
port =80

I click the CONNECT button and receive the following messages:

Connecting to local site......

What am I doing wrong????

FYI: I have been using DEPLOY wizard and the FileZilla FTP to successfully load my pages and db to my online host and everything runs fine.
2nd question: All I am attempting to do with WAMP is design and test locally with dbQwiksite on one PC. Is there a better way to do this?

Author:  Gerald [ Thu Feb 10, 2011 2:55 pm ]
Post subject:  Re: Newbie needs help with WAMP server, please?

First thing to check is that you are not running IIS on port 80. If you are, then Apache will not start. Check the statun in your wamp system tray icon if Apache is running or not. If it is running, it will offer you to "stop service" but if it is not running you'll see an option to "start service"

Author:  webwork [ Fri Feb 11, 2011 5:17 am ]
Post subject:  Re: Newbie needs help with WAMP server, please?

For Wamp go to Apache>Service>TEST PORT 80
You will get a reply telling you if port 80 is free, if it is not free reply back here.
If Wamp is running correctly the system tray icon will appear all white with no yellow or red markings.
It sounds like you are trying to FTP into Wamp.
You do not FTP into Wamp on the local machine.
You should go to c:\wamp\www and add a directory for your website like c:\wamp\www\website1
Then go to Apache>Alias Directories>Add an Alias.
Follow the instructions for adding an Alias then after you add an Alias publish your site directly into the c:\wamp\www\website1
You can then go to http://localhost/[ALIAS YOU JUST CREATED] to see your website.
Gerald you owe me big time... :mrgreen:

Page 1 of 1 All times are UTC + 7 hours
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group